Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Sortie de la version 1.2.2 de Lazarus
Une version corrective qui s'appuie sur Free Pascal 2.6.4

Le , par Ph. B.

9PARTAGES

1  0 
Sortie de la version 1.2.2 de Lazarus
Il s'agit d'une version corrective, mais qui s'appuie sur la dernière version de FreePascal 2.6.4



Bonjour à tous,

L'équipe en charge du développement de Lazarus vient de publier une nouvelle version de l'EDI selon le
communiqué officiel en date du 21 avril.

La version 1.2.2 est disponible au téléchargement ICI.

Elle s'appuie sur la version 2.6.4 du compilateur alors que les versions précédentes 1.0.x à 1.2.0, utilisaient la 2.6.2.

La liste des changements peut être consultée ICI.

Pour rappel, Lazarus peut fonctionner avec différents systèmes d'exploitation, les prérequis minimaux sont :
  • Windows : 98.
    Sous Windows, l'installeur autorise 2 installations indépendantes. Plus de détails ICI
    Sous Windows 64 bits, il est toutefois préconisé d'utiliser la version 32 bits (avec compilateur croisé 32/64 bits pour ceux pour qui le 64 bits est indispensable). Plus de détails ICI.
  • FreeBSD/Linux : gtk 2.8 ou qt4.5, 32 ou 64 bits.
  • Mac OS X : 10.5 pour les stations à base de processeur Intel, 10.4 pour celles à base de PowerPc ; LCL seulement 32 bits, les applications n'utilisant pas la LCL peuvent être 64 bits.

Ceux qui récupèrent les sources de l'EDI peuvent le faire depuis le dépôt SVN en utilisant le tag : http://svn.freepascal.org/svn/lazaru.../lazarus_1_2_2

Pour ceux d'entre vous qui seraient bloqués par SourceForge, cette version est accessible sur les sites miroirs suivants :
ftp://freepascal.dfmk.hu/pub/lazarus/releases/
puis après synchronisation :
http://michael-ep3.physik.uni-halle....arus/releases/
et :
http://mirrors.iwi.me/lazarus/

Qu'en pensez-vous ?

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de tintinux
Membre éprouvé https://www.developpez.com
Le 25/04/2014 à 13:53
Bonjour,

C'est une bonne nouvelle, car on ne peut pas utiliser la version 1.2.0, à cause d'un bug sur les TStringGrid / TDbGrid quand il y a un bouton de sélection dans une colonne (cbElipsis).

Il est apparemment corrigé, mais il semble que l'on ne puisse plus installer ZeosLib 7.1.2 avec cette nouvelle version la 1.2.2 (sans doute à cause de FPC 2.6.4).

La toute dernière version stable de ZeosLib 7.1.3a s'installe, mais il va falloir tout re-tester à fond. Le passage de 7.0 à 7.1.2 avait provoqué des problèmes bloquants, qui ont nécessité des reprises des applicatifs...

C'est vraiment regrettable que chaque nouvelle mise à jour de Lazarus mélange les résolutions de bugs et des nouvelles fonctionnalités ou des optimisations (fpc) qui en apportent d'autres (des bugs).
1  0 
Avatar de setchy
Inactif https://www.developpez.com
Le 20/05/2014 à 4:39
moi je préfère CodeTyphon, basé sur FPC 2.7.1. la version actuellle, 4.80 fonctionne bien sous win 7, et ubuntu 12.04 (les 2 en 32 et 64bits). pas rencontré de soucis avec les stringgrid ni Zeos ! ça glisse tout seul et le cross-compilation android aussi

http://www.pilotlogic.com/sitejoom/ << pour obtenir les sources et créer les compilateurs et l'IDE Lazarus amélioré "in situ" sur vos PC
1  0 
Avatar de Jon Shannow
Membre extrêmement actif https://www.developpez.com
Le 25/04/2014 à 16:10
Aussitôt installée... aussitôt désinstallée !
Les packages ZeosLib ne se compilent plus !

Merci Lazarus !
0  0 
Avatar de tintinux
Membre éprouvé https://www.developpez.com
Le 25/04/2014 à 18:58
Citation :
Le développeur Lazarus lira attentivement le message qui précède, même s'il est à juste titre persuadé qu'il lui reste beaucoup à apprendre.
0  0