Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Sortie de la version 2.0.2 de Lazarus
Une version corrective toujours fondée sur Free Pascal 3.0.4

Le , par gvasseur58

108PARTAGES

13  0 
L’équipe Lazarus vient d’annoncer la sortie de la version corrective 2.0.2 de l’EDI fondé sur Free Pascal 3.0.4.

La liste des corrections montre que les principaux axes de travail ont concerné :
  • la LCL pour wince ;
  • le composant TAChart encore une fois en forte progression ;
  • LazDebugger(Fp)Lldb, comme on devait s’y attendre après sa récente introduction.


En plus de ces quelques priorités ont été corrigés quelques bogues dont certains pouvaient conduire à un crash de l’EDI lui-même. La liste de tous les bogues traités est fournie ici (en anglais).

Comme d’habitude, cette nouvelle version est disponible sur SourceForge :
https://sourceforge.net/projects/lazarus/files/

Pour le téléchargement, vous devrez choisir votre processeur, votre système d’exploitation, votre distribution et le répertoire Lazarus 2.0.2.

Pour rappel, Lazarus fonctionne avec :

  • Windows 2k, XP, Vista, 7, 8, 8.1 et 10, en 32 ou 64 bits.
  • FreeBSD/Linux sous gtk 2.8 pour gtk2, qt4.5 pour qt, qt5.6 pour qt5, en 32 ou 64 bits.
  • Mac OS X de 10.5 à 10.12, Carbon (32 bits), Cocoa (64 bits, mais en bêta), qt et qt5 (en 32 ou 64 bits).


Source : Lazarus

Allez-vous utiliser cette version corrective de Lazarus ?
Que pensez-vous des améliorations apportées à l'EDI ?

Retrouvez les meilleurs cours et tutoriels pour apprendre la programmation avec Lazarus.

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de Jipété
Expert éminent sénior https://www.developpez.com
Le 18/05/2019 à 21:58
Bonsoir,

oui je sais, c'est mineur, extrêmement mineur, mais ça peut quand même induire en erreur alors, question, ça a été corrigé, cette inorganisation, cette pagaille dans la tête de celui qui a écrit ça ?


Merci,
0  0