Lazarus 2.0RC2 est disponible
Un nouveau pas vers la version stable

Le , par gvasseur58, Responsable Delphi
Conformément à sa feuille de route, l'équipe de Lazarus vient de sortir la toute nouvelle version 2.0 RC2 de l'EDI, préparatoire à celle qui sera déclarée stable. Il s'agissait d'apporter des correctifs à la récente Release Candidate 1 : correction de bogues, bien sûr, mais aussi améliorations variées.

Le soin apporté à l'élaboration de cette version majeure de l'EDI est allé jusqu'aux détails avec la limitation des messages lors de la compilation de l'EDI lui-même, des images mieux adaptées, des présentations plus sophistiquées, une meilleure compatibilité avec Delphi et des traductions mises à jour (dont la traduction française que nous prenons en charge !). Certains comportements par défaut ont été corrigés : ainsi, il n'y a plus de dump automatique en cas d'exception via DebugLn ni de logger par défaut (LazLogger), ces deux modifications étant justifiées par la souplesse de choix laissée aux développeurs.



En ce qui concerne les principaux changements, rappelons qu'ils concernent surtout les images avec les résolutions multiples et le high-DPI, la prise en charge de pas2js (lien avec JavaScript) et le débogueur fondé sur LLDB pour MacOS. D'autres fonctionnalités ont été implémentées dont la prise en compte des déplacements horizontaux du bouton de certaines souris.

L'invitation est donc faite aux utilisateurs de Lazarus de tester cette nouvelle mouture de leur EDI préféré en vue de la sortie prochaine de la version RC3, prélude (enfin !) à la version stable.

Source : Lazarus

Allez-vous tester cette version de Lazarus ?
Que pensez-vous des améliorations apportées à l'EDI ?

Retrouvez les meilleurs cours et tutoriels pour apprendre la programmation avec Lazarus.


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse Signaler un problème

Avatar de Selzig Selzig - Membre du Club https://www.developpez.com
le 01/11/2018 à 12:49
Bonjour Gilles,
Citation Envoyé par gvasseur58 Voir le message
[...]une meilleure compatibilité avec Delphi[...]
Avec Delphi 7 je suppose parce qu'avec Delphi XE aucune chance... à moins de choisir la même plate-forme graphique VGScene*, le LiveBinding... L'équipe court toujours après Delphi alors qu'au départ, au départ seulement, elle a choisi une meilleure approche que celle de... Borland (Qt) en voulant utiliser les objets graphiques natifs de chaque OS. Ceci dit comme le conseille BeanzMaster, j'essaierai d'installer la version déclarée stable sur Mac OS X à condition évidemment qu"elle soit encore compatible : je viens d'installer ce matin une mise à jour de xCode pour Mojave ...

*Dans un autre arcticle
Citation Envoyé par Paul TOTH Voir le message
Eugene a conçu VGScene pour Delphi qui est devenu Firemonkey quand KSDev a été racheté par Embarcadero, mais il ne bosse plus plus Embarcedero/Idera...ce qui explique que les productions ci-dessus soient vendues séparément de Delphi.
A l'époque (~2010), KSDEV avait produit un add-on pour Lazarus.

Cordialement. Gilles
Avatar de Jipété Jipété - Expert éminent sénior https://www.developpez.com
le 01/11/2018 à 23:00
Bonsoir,
Citation Envoyé par gvasseur58 Voir le message
Allez-vous tester cette version de Lazarus ?
Peut-être. Ça dépendra des réponses aux questions suivantes :

Citation Envoyé par gvasseur58 Voir le message
Que pensez-vous des améliorations apportées à l'EDI ?
Est-ce que ce que je signalais il y a deux ans a été pris en compte ? Est-ce qu'on peut enfin vraiment gérer la palette de composants ?

Et l'aide (post suivant du lien précédent) ? "Ils" ont bossé sur l'aide ?

Merci pour les retours,
Avatar de Roland Chastain Roland Chastain - Rédacteur/Modérateur https://www.developpez.com
le 02/11/2018 à 15:48
Une opinion personnelle. C'est dommage que l'icône de Lazarus soit si moche. Quelqu'un connaîtrait-il la procédure pour reconstruire Lazarus avec une icône différente ?

L'icône des projets, ça passe encore. Mais l'icône de l'EDI !
Avatar de gvasseur58 gvasseur58 - Responsable Delphi https://www.developpez.com
le 02/11/2018 à 19:06
Bonjour à tous !

@Gilles (non, je ne me réponds pas !) : oui, tu as raison, quand on parle de meilleure compatibilité avec Delphi, il faudrait préciser pour la partie VCL. L'objectif n'est cependant plus d'atteindre le niveau de Delphi 7 (dépassé depuis longtemps), mais bien celui des versions plus modernes.

@Jipété : je crains que ton attente ne soit déçue... Des travaux sur l'aide ont été réalisés, mais je crois qu'ils ne concernaient que la présentation. Quant à la palette, il n'est pas si facile que ça d'y toucher, mais ce serait un défi à se lancer, pourquoi pas ? Déjà, il faudrait pouvoir modifier l'EDI avec les outils proposés : je dois avouer que j'ai à peine essayé deux ou trois bricoles.

@Roland : si tu détestes cette icône, ce n'est pas si simple que ça de la changer : les changements d'options et la reconstruction de l'EDI ne suffisent pas sous Windows (l'icône est sans doute associée lors de l'installation).

Cordialement,

Gilles
Avatar de Jipété Jipété - Expert éminent sénior https://www.developpez.com
le 03/11/2018 à 10:53
Citation Envoyé par gvasseur58 Voir le message
@Jipété : je crains que ton attente ne soit déçue... Des travaux sur l'aide ont été réalisés, mais je crois qu'ils ne concernaient que la présentation. Quant à la palette, il n'est pas si facile que ça d'y toucher, mais ce serait un défi à se lancer, pourquoi pas ? Déjà, il faudrait pouvoir modifier l'EDI avec les outils proposés : je dois avouer que j'ai à peine essayé deux ou trois bricoles.
Merci pour le retour, je vais donc sagement rester avec mon 1.4 (et 1.8.2 dans une machine de test) qui me donne entière satisfaction (sauf l'aide, mais ce n'est pas nouveau).
Responsables bénévoles de la rubrique Lazarus : Alcatîz - Gilles Vasseur -